Error
Unable to access "MEDISPAN" database
Cause
- At the time of setup, the provided Datavant Site Connect database user was not granted read access to this database.
- During an update to the Medispan DB, access to the Medispan DB was not reapplied to the Datavant Site Connect user account.
Impact
For the Datavant Site Connect agent to pull NDC and generic drug data, the Datavant Site Connect agent requires access to the Allscripts Pro medispan database.
Note: This database is updated often by Allscripts or assigned DB admins to keep the drug database current.
Resolution
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Request that your DB Admins or Allscripts reps reapply the read access to the Medispan DB to the Datavant Site Connect user account.
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Self Service:
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Open your Allscripts DB instance in SSMS
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Open the query editor
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Execute the following logic, where 'sql_username' is the provided Datavant Site Connect Account:
USE master
ALTER DATABASE MEDISPAN SET READ_WRITE WITH NO_WAIT
USE MEDISPAN
EXEC sp_addrolemember 'db_datareader', 'sql_username'
USE master
ALTER DATABASE MEDISPAN SET READ_ONLY WITH NO_WAIT
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